Opened 5 years ago

Last modified 4 years ago

#18638 new defect

Graphics Issues, Machine Crashing on Linux Host and Windows 10 Guest

Reported by: Mike Vastola Owned by:
Component: 3D support Version: VirtualBox 6.0.6
Keywords: Cc:
Guest type: Windows Host type: Linux


So I've been having major trouble getting my Windows 10 Guest to work correctly (From an Ubuntu 18.10 host). I've been having major graphics issues lately, especially when I turn on VBoxSVGA, which I use with 2D and 3D acceleration enabled.

Just now after experiencing some weird issue's I'll go into in a bit and trying to reboot my machine, I got a message box telling me VirtualBox had to abort and to submit a ticket.

I'm attaching a log file for the ticket, as well as the VM Guest configuration file. As far as I know, everything is up to date and configured correctly.

I'm also attaching the output of lspci (for my host's graphics card) and a partial dump of dmesg as there are some warnings from VB kernel modules.

Some background: Basically, everything seems to be working intermittently graphics-wise. All the issues seem to be occurring due to crashes inside C:\WINDOWS\system32\VBoxSVGA.dll, including frequent windows in Desktop Window Manager (dwm.exe).

Additionally, sometimes I am getting the error "Display driver failed to start; using Microsoft Basic Display Driver instead. Check Windows Update for a newer display driver.". When this happens I have no choice but to restart because the guest's screen becomes totally black with a working cursor and a blurred version of the VB bios screen overlayed in white. There is no way to resolve this without a reboot.

When things get really bad, pretty much all apps refuse to launch (though the ones already launch still work) and they fail silently (this is really ironic and frustrating as this includes debugging apps), though for each attempt I see an error relating to VBoxSVGA.dll in the Windows Error Log. I am attaching several days worth of Windows Error Logs (Application Logs) in XML format in the hopes they contain some information. I'm also attaching an HTML export of the Windows Error Reports that were generated. (Unfortunately I didn't have saving minidumps enabled at the time.)

When this whole "nothing will start" phenomenon occurs a program that I'm frequently trying to use -- a 3D modeling program called Autodesk Fusion 360 -- actually freaks out because it will keep trying to restart a Chrome WebView process ad infinitum (obviously the ad infinitum bit isn't on VirtualBox). I've included a stack trace from a minidump of one of these crashes as it's one of the few minidumps I have. (I can't attach the minidump itself as the memory contains proprietary content.)

If anyone could offer any help, it would be greatly appreciated. I'm happy to assist with debugging this in any way I can.

Attachments (9)

ApplicationErrorLogs.xml (466.5 KB ) - added by Mike Vastola 5 years ago.
Windows Error Logs on Guest
dmesg (22.7 KB ) - added by Mike Vastola 5 years ago.
dmesg logs on host
lspci.txt (6.6 KB ) - added by Mike Vastola 5 years ago.
lspci on host
Mike10.vbox (17.2 KB ) - added by Mike Vastola 5 years ago.
VM Configuration
Mike10-2019-05-13-14-47-17.log.xz (72.9 KB ) - added by Mike Vastola 5 years ago.
VirtualBox Guest Machine Logs (xz'ed due to size)
minidump-backtrace.log (2.5 KB ) - added by Mike Vastola 5 years ago.
Backtrace from Application Minidump
ticket18638-release133662.png (259.2 KB ) - added by Mike Vastola 4 years ago.
Issue on Release 133662
VBVideoIssue-r133546.txt (10.0 KB ) - added by Mike Vastola 4 years ago.
WinDbg Analysis with Release 133568.txt
Neutron_minidump-r133546.dmp (482.9 KB ) - added by Mike Vastola 4 years ago.
Crash Minidump from Release 133568.dmp

Download all attachments as: .zip

Change History (20)

by Mike Vastola, 5 years ago

Attachment: ApplicationErrorLogs.xml added

Windows Error Logs on Guest

by Mike Vastola, 5 years ago

Attachment: dmesg added

dmesg logs on host

by Mike Vastola, 5 years ago

Attachment: lspci.txt added

lspci on host

by Mike Vastola, 5 years ago

Attachment: Mike10.vbox added

VM Configuration

by Mike Vastola, 5 years ago

VirtualBox Guest Machine Logs (xz'ed due to size)

by Mike Vastola, 5 years ago

Attachment: minidump-backtrace.log added

Backtrace from Application Minidump

comment:1 by MiSNemesis, 5 years ago

I have been getting lots of Black Screens myself on my Windows Server VMs. Forced to reboot, I don't see any errors or anything. Happens all over the place.

comment:2 by Mike Vastola, 5 years ago

Ok, so I have a few minidumps now but unfortunately they're all bigger than the 512 K size limit for this Trac install. Any suggestions on how to send them?

Also, I see a new version was just released. Will try it and let you guys know if anything is different.

Lastly, is there any way to get debug symbols (or a debug build) for the windows guest additions? I don't see them anywhere and I'd be happy to try debugging it myself. I tried to compile the source myself but it looks like I would need to compile it on windows and I have newer versions of all the software than what the build supports.

comment:3 by incident41, 5 years ago

Allow me to make a circular reference to my forum post describing what I believe is a very similar issue, if not downright the same:

comment:4 by Dmitrii Grigorev, 5 years ago

Hi Mike. Thank you for the report. Hope that the issue in VBoxSVGA.dll was fixed. Could you install the recent test build of Guest Additions onto your Windows 10 guest and check if the issue persists? Follow this link and choose "Latest 6.0.x test builds".

comment:5 by incident41, 5 years ago

FWIW, I tested installing guest additions 130987 in my Win10 guest VM and it's still broken ("Display driver failed to start" notification when 3D video acceleration is enabled).

Waiting for Mike's report to see whether it's good for him instead and I'm experiencing a different issue, not fixed by this build - if so I'll file another ticket.

comment:6 by incident41, 5 years ago

Coming back to this one, since my own issue is fixed in the current development snapshot Guest Additions... big thanks DmitrG!

Mike's own also shows the similar trait of > 2GB RAM for the Windows 10 VM (mine had 4GB, his has 8GB), it'd be interesting to know whether Mike could reproduce the workaround of running with 2GB RAM for the VM - or try out GA 132359 where I have no issue even at 4GB RAM.

by Mike Vastola, 4 years ago

Issue on Release 133662

comment:7 by Mike Vastola, 4 years ago

Hi Guys,

For some reason I didn't receive any notifications when this issue was submitted, so I apologize for neglecting this issue.

So I hadn't attempted to use this program on my VM in a bit, but trying just now with the latest release (6.0.12-133076) I'm running into the same issue as before.

I also went ahead and tried this with the latest development snapshot (133662), extension pack (133659) and guest additions (133663), the same issue didn't occur, but an even weirder one did. this is how the program rendered when it started, which was just bizarre.

I then tried with the latest 6.0.x test builds (133568) with Guest Additions (133546) and Extension Pack (133568) and I'm getting the same issues as with the latest release. I'm attaching the latest minidump and windbg analysis to this ticket.

by Mike Vastola, 4 years ago

Attachment: VBVideoIssue-r133546.txt added

WinDbg Analysis with Release 133568.txt

by Mike Vastola, 4 years ago

Crash Minidump from Release 133568.dmp

comment:8 by Mike Vastola, 4 years ago

Also, I should note I'm no longer experiencing the whole "Apps refusing to start" issue, but (and I'm not sure if the issue has mutated or this is due to other instability with using a test release) I am having issues where the Guest keeps aborting and/or restarting.

One such issue just triggered what is apparently called a kernel bugcheck in windows, which triggered the creation of a dump file which -- when opened in WinDbg -- was analyzed as follows.

*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

This bugcheck is generated when the kernel detects that critical kernel code or
data have been corrupted. There are generally three causes for a corruption:
1) A driver has inadvertently or deliberately modified critical kernel code
 or data. See
2) A developer attempted to set a normal kernel breakpoint using a kernel
 debugger that was not attached when the system was booted. Normal breakpoints,
 "bp", can only be set if the debugger is attached at boot time. Hardware
 breakpoints, "ba", can be set at any time.
3) A hardware corruption occurred, e.g. failing RAM holding kernel code or data.
Arg1: a39fd4e6acb8d7a9, Reserved
Arg2: b3b6e16cff3b09e4, Reserved
Arg3: 0000000000000006, Failure type dependent information
Arg4: 000000000000001d, Type of corrupted region, can be
	1d  : Executive callback object modification

Debugging Details:


    Key  : Analysis.CPU.Sec
    Value: 2

    Key  : Analysis.DebugAnalysisProvider.CPP
    Value: Create: 8007007e on MIKE10-VASTDESK

    Key  : Analysis.DebugData
    Value: CreateObject

    Key  : Analysis.DebugModel
    Value: CreateObject

    Key  : Analysis.Elapsed.Sec
    Value: 2

    Key  : Analysis.Memory.CommitPeak.Mb
    Value: 58

    Key  : Analysis.System
    Value: CreateObject



BUGCHECK_P1: a39fd4e6acb8d7a9

BUGCHECK_P2: b3b6e16cff3b09e4



BLACKBOXBSD: 1 (!blackboxbsd)


fffff008`02ea69e8 00000000`00000000 : 00000000`00000109 a39fd4e6`acb8d7a9 b3b6e16c`ff3b09e4 00000000`00000006 : nt!KeBugCheckEx


MODULE_NAME: Unknown_Module

IMAGE_NAME:  Unknown_Image

STACK_COMMAND:  .thread ; .cxr ; kb


OS_VERSION:  10.0.17763.1

BUILDLAB_STR:  rs5_release


OSNAME:  Windows 10

FAILURE_ID_HASH:  {b4d7023a-05c3-49b2-3ea4-6240fe57d90e}

Followup:     MachineOwner

I imagine this is related because the listed #1 cause is "A driver has inadvertently or deliberately modified critical kernel code".

Please let me know if there is any other info I can provide to help track this down.

comment:9 by Mike Vastola, 4 years ago

Question: are there any published versions of the Guest Additions with Windows Debug Symbols? I'd be happy to give a shot at tracing this issue myself, but I can't seem to find any such versions and my head still hurts from trying (unsuccessfully) to spin up a build environment. (The instructions seem really outdated.)

in reply to:  9 comment:10 by Socratis, 4 years ago

Replying to Mike Vastola:

Question: are there any published versions of the Guest Additions with Windows Debug Symbols?

No, you'd have to build VirtualBox from source for that.

comment:11 by Dmitrii Grigorev, 4 years ago

Hi Mike. Your recent problem description does not match ticket header. It must be more specific to " ... Autodesk Fusion 360 problems with 3D acceleration ...", is not it? Could you create a new ticket with description of the steps leading to BugCheck in guest VM?

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use