Opened 5 years ago

Closed 5 years ago

#18207 closed defect (fixed)

VM shortcut start does not work (anymore) -> fixed after (not in) 6.0.0 and in test builds

Reported by: DJ Doena Owned by:
Component: GUI Version: VirtualBox 6.0.0
Keywords: Cc:
Guest type: Windows Host type: Windows


I tried to use the old 5.x shortcut to start a specific machine, but got

--startvm ist eine Option für die VirtualBox VM-Ausführungs-Anwendung (VirtualBoxVM), nicht den VirtualBox Manager.

which basically says "--startvm" is not a valid parameter. OK, so something's changed with 6.0 No prob. Use VirtualManager 6.0

VirtualBox graphische Benutzeroberfläche
Version 6.0.0 r127566 (Qt5.6.2)
Copyright © 2018 Oracle Corporation and/or its affiliates. All rights reserved.

to create a new shortcut. Said and done. Same error.

Shortcut created puts the execution instruction as such:

"C:\Program Files\Oracle\VirtualBox\VirtualBox.exe" --comment "VM-Name" --startvm "{139ad888-e3c1-4220-8a36-751414cb3c47}"

Attachments (1)

vb.png (6.5 KB ) - added by DJ Doena 5 years ago.

Download all attachments as: .zip

Change History (14)

by DJ Doena, 5 years ago

Attachment: vb.png added

comment:1 by Bigos, 5 years ago

Please try VirtualBoxVM.exe instead of VirtualBox.exe. I think the executable for launching VMs has changed in 6.0 and is now different from the dashboard one.

comment:2 by pjanssen, 5 years ago

When using 6.0 to create shortcuts on the desktop it still uses VirtualBox.exe. Manually changing the shortcut to VirtualBoxVM.exe works. The shortcut should be created with the correct executable.

I think the problem is in these lines:

Last edited 5 years ago by pjanssen (previous) (diff)

comment:3 by ploni, 5 years ago

Same issue also occurs on Linux.

in reply to:  2 comment:4 by Socratis, 5 years ago

Replying to pjanssen:

I think the problem is in these lines:

Great finding! However, I find it best to link to the source code directly, instead of a copy of the tree in Github (which is not maintained BTW) from 2014:

comment:5 by kyrios, 5 years ago

Same problem on linux. Edit the shortcut and replace the executable "VirtualBox" with "VirtualBoxVM"

Last edited 5 years ago by kyrios (previous) (diff)

comment:6 by Juan Simón, 5 years ago

Same here on Arch Linux

comment:7 by pentagonik, 5 years ago

Thanks for the report. This issue will be fixed in the next upcoming maintenance version.

comment:8 by Michael Thayer, 5 years ago

Summary: VM shortcut start does not work (anymore)VM shortcut start does not work (anymore) -> fixed after (not in) 6.0.0 and in test builds

Please try a current test build<1>. Please note that non-development test builds should be as stable as release builds for most purposes.

  1. wiki:Testbuilds

comment:9 by andaris, 5 years ago

Apparently, the file associations for .vbox and .vbox-extpack file extensions also do not work anymore (Virtualbox 6.0.0 on Windows 10 1809)

Thank you!

comment:10 by Socratis, 5 years ago


This ticket is for the shortcuts only. There are two other tickets for all file associations:

  • #18206 Error when installing Extension Pack
  • #18197 OSX: Dbl-clicking on registered file types results in no action

comment:11 by pentagonik, 5 years ago

Right, creating shortcuts (what this ticket is about) and actually launching stuff from registered file types are two completely separate things.

comment:12 by andaris, 5 years ago

Ok, thank you very much for your feedback. Then I'll watch the other tickets for the file associations.

comment:13 by Michael Thayer, 5 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use