Opened 7 years ago

Last modified 5 years ago

#17067 new defect

Dir Copy Fails to Copy Files to Shared Dir

Reported by: Craig100 Owned by:
Component: other Version: VirtualBox 5.1.26
Keywords: Copy Shared Folder Cc:
Guest type: Windows Host type: Linux


Running VB Version 5.1.26 r117224 (Qt5.5.1) on Linux Mint 18.2 Cinnamon x64. Guest is Windows 10 Home x64 version 10.0.15063. All with latest updates (including the Creator's Update). Several shared folders set up on the Host. Shared Clipboard & Drag and Drop set to Bidirectional. VB.log attached.

Problem: Copying a directory FROM the Windows 10 guest to a Linux Shared Directory results in only the first directory being created. No files or sub-directories are copied. This has only been the case since Windows 10 Creator's Update installed. The last version that did not have this problem was 5.1.22 but that was before the Creator's Update installed.

Steps to reproduce:-

  1. In the Windows 10 Guest open two instances of File Explorer.
  2. Set one to a directory containing files on the Guest and the other to a Shared Folder on the Host.
  3. Drag the Windows directory to the Shared folder.

I'm finding nothing is transferred except the top-most directory but none of it's children.

This forum post refers: ​

Attachments (1)

VBox.log (117.3 KB ) - added by Craig100 7 years ago.
VB Log File

Download all attachments as: .zip

Change History (7)

by Craig100, 7 years ago

Attachment: VBox.log added

VB Log File

comment:1 by Socratis, 7 years ago

One unconfirmed ​report by user Ben85 in the linked forum discussion, claims that using "xcopy" to perform the same operation seems to work correctly. Craig100, could you verify that?

comment:2 by Craig100, 7 years ago

As a diagnostic test I can confirm that using the following CLI line in Windows 10 copied all the directories, subdirectories, files and hidden files correctly, all 1246 of them:-

Xcopy /S /I /E /H C:\WebProjects\MyProject G:\Transfer\MyProject

The G drive being a shared drive on the Linux host.

comment:3 by Bobbix, 7 years ago

I confirm the bug! (Windows 10 x64 Host). Command line xcopy work fine but not copying via Windows GUI. I think can be a Guest Additions bug or something like.

The copy start but stop immediatly without any error message resulting in a only first folder copy or some few files/dir into. No problems found copying FROM virtuabox shared folder to guest. Mounting shares via IP address the copy via GUI work fine.

I can confirm this problem at least on three Windows 10 guests (Creators Update) test installations.

Last edited 7 years ago by Bobbix (previous) (diff)

comment:4 by bblackmoor, 5 years ago

I have this same problem. This is NOT caused by a leading dot in a file name or directory name, because there are not any.

D:\Documents\Downloads is shared from the host to the guest, as "Downloads", which I have assigned to Z: in the guest OS.

Opening two file windows in the guest, one at C:\Downloads, the other at Z:

Select four directories in guest window. Attempt to copy and paste, or drag and drop, to the shared folder copies only the first directory, and does not copy any of its contents.

Repeated copy/paste or drag/drop will copy the next (empty) directory, and then the next, and so on until all of the directories have been copied. After that, the next copy/paste or drag/drop will copy the directory contents.

This is a new problem for me: everything worked fine a week ago.

I have:

  • Updated VirtualBox from 5 to 6 (I was using 5 when this problem first appeared).
  • Installed the new extension pack (copy/paste or drag/drop will copy the next (empty) directory).
  • Re-installed the Guest Additions several times.

I am sorely vexed.

See also:

comment:5 by bblackmoor, 5 years ago

I removed the shared folder, rebooted the VM, and re-created the shared folder. Same problem.

comment:6 by boxer01, 5 years ago

Could somebody check this issue on the some current version, at least 6.0.8 / 6.0.9 or 5.2.30 / 5.2.31? It looks like it’s solved in my other ticket #17626.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use