1 | #!/usr/bin/make -f
|
---|
2 | #
|
---|
3 | # Copyright (C) 2006-2008 Sun Microsystems, Inc.
|
---|
4 | #
|
---|
5 | # This file is part of VirtualBox Open Source Edition (OSE), as
|
---|
6 | # available from http://www.virtualbox.org. This file is free software;
|
---|
7 | # you can redistribute it and/or modify it under the terms of the GNU
|
---|
8 | # General Public License as published by the Free Software Foundation,
|
---|
9 | # in version 2 as it comes in the "COPYING" file of the VirtualBox OSE
|
---|
10 | # distribution. VirtualBox OSE is distributed in the hope that it will
|
---|
11 | # be useful, but WITHOUT ANY WARRANTY of any kind.
|
---|
12 | #
|
---|
13 |
|
---|
14 | #export DH_VERBOSE=1
|
---|
15 | export DH_COMPAT=4
|
---|
16 |
|
---|
17 | # possible overrides:
|
---|
18 | # OSE=1 force VBOX_OSE
|
---|
19 | # NOPARALLEL=1 compile with -j1 (-j2 is default)
|
---|
20 | # LINUX=<dir> compile vboxdrv against Linux found in <dir>
|
---|
21 | # VERBOSE=1 verbose build
|
---|
22 | # DEBUG=1 debug build
|
---|
23 | # NOSUBVER=1 disable generation of the sub-version field (which is
|
---|
24 | # either the subversion rev [if available] or the build date)
|
---|
25 | # NODOCS=1 don't build docs, use precompiled UserManual.pdf and
|
---|
26 | # VirtualBox.chm from $HOME
|
---|
27 | # NOMODS=1 don't build any module
|
---|
28 | # HEADLESS=1 build the headless version
|
---|
29 | # STAGEDISO=<path> don't build the VBoxAdditions, use the precompiled .iso
|
---|
30 |
|
---|
31 | package := virtualbox
|
---|
32 | verpkg := virtualbox-ose
|
---|
33 | current := $(shell pwd)
|
---|
34 | vboxroot := $(shell pwd)
|
---|
35 | builddir := $(current)/debian/builddir
|
---|
36 | moddir := $(current)/debian/modules
|
---|
37 | prefix := $(current)/debian/$(verpkg)
|
---|
38 | arch := $(shell dpkg --print-architecture)
|
---|
39 | verfile := $(builddir)/version-generated.mk
|
---|
40 | ose := 1
|
---|
41 | NOMODS ?= $(ose)
|
---|
42 |
|
---|
43 | ifneq ($(wildcard $(verfile)),)
|
---|
44 | include $(verfile)
|
---|
45 | ver := $(VBOX_VERSION_STRING)
|
---|
46 | archdir := $(prefix)/opt/VirtualBox-$(ver)
|
---|
47 | endif
|
---|
48 |
|
---|
49 | ifneq ($(STAGEDISO),)
|
---|
50 | ifeq ($(wildcard $(STAGEDISO)/VBoxGuestAdditions.iso),)
|
---|
51 | $(error STAGEDISO='$(STAGEDISO)/VBoxGuestAdditions.iso' not found)
|
---|
52 | endif
|
---|
53 | endif
|
---|
54 |
|
---|
55 | # Hack: Xandros is actually Debian/sarge ... :(
|
---|
56 | ifneq ($(wildcard /etc/xandros-desktop-version),)
|
---|
57 | debrel := _xandros4.1
|
---|
58 | else
|
---|
59 | ifneq ($(wildcard /etc/univention),)
|
---|
60 | debrel := _ucs1.3
|
---|
61 | else
|
---|
62 | debrel := $(if $(shell which lsb_release),_$(shell lsb_release -si)_$(shell lsb_release -sc),)
|
---|
63 | endif
|
---|
64 | endif
|
---|
65 |
|
---|
66 | gccver := $(subst ., ,$(shell gcc -dumpversion))
|
---|
67 | gccvmaj := $(word 1,$(gccver))
|
---|
68 | gccvmin := $(word 2,$(gccver))
|
---|
69 | debcfgs := VBOX_PATH_PACKAGE_DOCS="\"/usr/share/doc/$(verpkg)\""
|
---|
70 |
|
---|
71 | # Ubuntu dapper: gcc-4.0 does not work with recompiler, use gcc-3.4 instead
|
---|
72 | configure: debian/configure-stamp
|
---|
73 | debian/configure-stamp:
|
---|
74 | dh_testdir
|
---|
75 | cd $(vboxroot) && ./configure --odir=$(current)/debian --disable-qt3 $(if \
|
---|
76 | $(ose),--ose,) $(if $(LINUX),--with-linux=$(LINUX),) $(if \
|
---|
77 | $(filter _Ubuntu_dapper,$(debrel)),--with-gcc=gcc-3.4 --with-g++=g++-3.4,) $(if \
|
---|
78 | $(shell test $(gccvmaj) -eq 4 -a $(gccvmin) -gt 2 -o $(gccvmaj) -gt 4 && echo "yes"),--with-gcc=gcc-4.2 --with-g++=g++-4.2,) $(if \
|
---|
79 | $(filter _xandros4.1 _ucs1.3,$(debrel)),--disable-sdl-ttf,) $(if \
|
---|
80 | $(HEADLESS),--build-headless,) $(if $(DEBUG),--build-debug,)
|
---|
81 | touch debian/configure-stamp
|
---|
82 |
|
---|
83 | build: debian/configure-stamp debian/build-stamp
|
---|
84 | debian/build-stamp $(verfile):
|
---|
85 | dh_testdir
|
---|
86 | . debian/env.sh && kmk -C $(vboxroot) $(if \
|
---|
87 | $(VERBOSE),--print-directory,--no-print-directory) $(if \
|
---|
88 | $(NOPARALLEL),-j1,-j2) $(if \
|
---|
89 | $(VERBOSE),KBUILD_VERBOSE=2,) $(if \
|
---|
90 | $(NODOCS),VBOX_WITH_DOCS=,)\
|
---|
91 | $(if $(STAGEDISO),VBOX_WITHOUT_ADDITIONS=1,) \
|
---|
92 | AUTOCFG=$(current)/debian/AutoConfig.kmk \
|
---|
93 | LOCALCFG=$(current)/debian/LocalConfig.kmk \
|
---|
94 | PATH_OUT=$(current)/debian/builddir \
|
---|
95 | VBOX_DO_STRIP= VBOX_DO_STRIP_MODULES= \
|
---|
96 | $(debcfgs) \
|
---|
97 | all
|
---|
98 | $(if $(NODOCS),cp $(vboxroot)/prebuild/UserManual.pdf $(builddir)/bin,)
|
---|
99 | $(if $(NODOCS),cp $(vboxroot)/prebuild/VirtualBox.chm $(builddir)/bin,)
|
---|
100 | mkdir -p $(builddir)/bin/additions
|
---|
101 | $(if $(STAGEDISO),cp $(STAGEDISO)/VBoxGuestAdditions.iso $(builddir)/bin/additions,)
|
---|
102 | . debian/env.sh && kmk -C $(vboxroot) $(if \
|
---|
103 | $(VERBOSE),--print-directory,--no-print-directory) $(if \
|
---|
104 | $(VERBOSE),KBUILD_VERBOSE=2,) $(if \
|
---|
105 | $(STAGEDISO),VBOX_WITHOUT_ADDITIONS=1,) \
|
---|
106 | AUTOCFG=$(current)/debian/AutoConfig.kmk \
|
---|
107 | LOCALCFG=$(current)/debian/LocalConfig.kmk \
|
---|
108 | PATH_OUT=$(current)/debian/builddir \
|
---|
109 | VBOX_DO_STRIP= VBOX_DO_STRIP_MODULES= \
|
---|
110 | VBOX_NO_LINUX_RUN_INSTALLER=1 \
|
---|
111 | $(debcfgs) \
|
---|
112 | packing
|
---|
113 | touch debian/build-stamp
|
---|
114 |
|
---|
115 | # Build modules for every kernel we find in /lib/modules/*
|
---|
116 | modules: debian/build-stamp debian/modules-stamp
|
---|
117 | debian/modules-stamp: debian/build-stamp
|
---|
118 | rm -rf $(moddir)
|
---|
119 | mkdir $(moddir)
|
---|
120 | make -C $(builddir)/bin/src clean
|
---|
121 | for d in $(wildcard /lib/modules/*); do \
|
---|
122 | if [ -L $$d/build ]; then \
|
---|
123 | make -C $(builddir)/bin/src KERN_DIR=$$d/build MODULE_DIR=$$d clean all && \
|
---|
124 | install -D -m 0644 -g 0 -o 0 \
|
---|
125 | $(builddir)/bin/src/vboxdrv.ko $(moddir)/$$(basename $$d)/vboxdrv.ko; \
|
---|
126 | fi; \
|
---|
127 | done
|
---|
128 | make -C $(builddir)/bin/src clean
|
---|
129 | touch debian/modules-stamp
|
---|
130 |
|
---|
131 | clean:
|
---|
132 | dh_testdir
|
---|
133 | dh_testroot
|
---|
134 | rm -f debian/$(package).init debian/vboxdrv.init debian/vboxnet.init
|
---|
135 | rm -f debian/AutoConfig.kmk debian/configure.log debian/env.sh debian/preinst
|
---|
136 | rm -f debian/modules-stamp debian/build-stamp debian/configure-stamp
|
---|
137 | rm -rf $(builddir) $(moddir)
|
---|
138 | dh_clean
|
---|
139 |
|
---|
140 | ifeq ($(VBOX_VERSION_MAJOR),)
|
---|
141 | binary binary-arch binary-indep: build $(verfile)
|
---|
142 | $(MAKE) -f debian/rules binary
|
---|
143 | else
|
---|
144 | # Build architecture-dependent files here.
|
---|
145 | binary binary-arch binary-indep: build $(if $(NOMODS),,modules)
|
---|
146 | dh_testdir
|
---|
147 | dh_testroot
|
---|
148 | dh_clean -k
|
---|
149 | dh_installdirs
|
---|
150 | tar -xjC $(prefix)/opt -f $(builddir)/bin/VirtualBox.tar.bz2
|
---|
151 | install -d -g 0 -o 0 $(prefix)/usr/share/applications
|
---|
152 | install -d -g 0 -o 0 $(prefix)/usr/lib
|
---|
153 | install -d -g 0 -o 0 $(prefix)/usr/bin
|
---|
154 | install -d -g 0 -o 0 $(prefix)/usr/lib/$(package)
|
---|
155 | install -d -g 0 -o 0 $(prefix)/usr/share/$(package)
|
---|
156 | install -d -g 0 -o 0 $(prefix)/usr/share/doc/$(verpkg)
|
---|
157 | $(if $(HEADLESS),,mv $(archdir)/VirtualBox.desktop \
|
---|
158 | $(prefix)/usr/share/applications/VirtualBox.desktop)
|
---|
159 | install -d -g 0 -o 0 $(prefix)/usr/share/pixmaps
|
---|
160 | install -D -g 0 -o 0 -m 644 debian/lintian-override \
|
---|
161 | $(prefix)/usr/share/lintian/overrides/$(package)
|
---|
162 | mv $(archdir)/VBox.png \
|
---|
163 | $(prefix)/usr/share/pixmaps/VBox.png
|
---|
164 | mv $(archdir)/*.gc $(prefix)/usr/lib/$(package)
|
---|
165 | mv $(archdir)/*.r0 $(prefix)/usr/lib/$(package)
|
---|
166 | $(if $(filter amd64,$(arch)),\
|
---|
167 | mv $(archdir)/VBoxREM2.rel $(prefix)/usr/lib/$(package),)
|
---|
168 | mv $(archdir)/VBoxXPCOMIPCD $(prefix)/usr/lib/$(package)
|
---|
169 | mv $(archdir)/components $(prefix)/usr/lib/$(package)/components
|
---|
170 | mv $(archdir)/*.so $(prefix)/usr/lib/$(package)
|
---|
171 | mv $(archdir)/*.so.4 $(prefix)/usr/lib/$(package) || true
|
---|
172 | $(if $(HEADLESS),,mv $(archdir)/nls $(prefix)/usr/share/$(package))
|
---|
173 | mv $(archdir)/src $(prefix)/usr/share/$(package)
|
---|
174 | rm $(archdir)/VBox.sh
|
---|
175 | install -D -g 0 -o 0 -m 644 debian/VBox.sh $(prefix)/usr/bin/VBox
|
---|
176 | mv $(archdir)/VBoxSysInfo.sh $(prefix)/usr/share/$(package)
|
---|
177 | mv $(archdir)/VBoxAddIF.sh $(prefix)/usr/bin/VBoxTAP
|
---|
178 | for i in VBoxManage VBoxSVC $(if $(HEADLESS),,VBoxSDL) \
|
---|
179 | $(if $(HEADLESS),,VirtualBox) $(if $(ose),,VBoxVRDP) \
|
---|
180 | VBoxHeadless; do \
|
---|
181 | mv $(archdir)/$$i $(prefix)/usr/lib/$(package); done
|
---|
182 | mv $(archdir)/VBoxTunctl $(prefix)/usr/bin
|
---|
183 | $(if $(NOMODS),,for d in $(moddir)/*; do \
|
---|
184 | install -D -g 0 -o 0 -m 0644 \
|
---|
185 | $$d/vboxdrv.ko $(prefix)/lib/modules/$$(basename $$d)/misc/vboxdrv.ko; done)
|
---|
186 | ifeq ($(ose),)
|
---|
187 | $(if $(HEADLESS),,mv $(archdir)/kchmviewer $(prefix)/usr/lib/$(package))
|
---|
188 | dh_installdocs $(addprefix $(archdir)/,\
|
---|
189 | UserManual.pdf VirtualBox.chm LICENSE)
|
---|
190 | rm $(addprefix $(archdir)/,UserManual.pdf VirtualBox.chm LICENSE)
|
---|
191 | for i in rdesktop-vrdp.tar.gz additions/VBoxGuestAdditions.iso; do \
|
---|
192 | mv $(archdir)/$$i $(prefix)/usr/share/$(package); done
|
---|
193 | rmdir $(archdir)/additions
|
---|
194 | else
|
---|
195 | dh_installdocs
|
---|
196 | endif
|
---|
197 | rmdir $(archdir)
|
---|
198 | rmdir $(prefix)/opt
|
---|
199 | dh_link \
|
---|
200 | $(if $(HEADLESS),,usr/bin/VBox usr/bin/VirtualBox) \
|
---|
201 | usr/bin/VBox usr/bin/VBoxManage \
|
---|
202 | $(if $(HEADLESS),,usr/bin/VBox usr/bin/VBoxSDL) \
|
---|
203 | $(if $(ose),,usr/bin/VBox usr/bin/VBoxVRDP) \
|
---|
204 | usr/bin/VBox usr/bin/VBoxHeadless \
|
---|
205 | usr/bin/VBoxTAP usr/bin/VBoxAddIF \
|
---|
206 | usr/bin/VBoxTAP usr/bin/VBoxDeleteIF
|
---|
207 | dh_desktop
|
---|
208 | dh_installmenu
|
---|
209 | $(if $(NOMODS),,dh_installmodules)
|
---|
210 | sed -e 's|%NOLSB%|$(if $(filter _Debian_sarge ucs1.3,$(debrel)),yes,)|g; s|%PACKAGE%|virtualbox|g;' \
|
---|
211 | src/VBox/Installer/linux/vboxdrv.sh.in > debian/vboxdrv.init
|
---|
212 | sed -e 's|%NOLSB%|$(if $(filter _Debian_sarge,$(debrel)),yes,)|g;' \
|
---|
213 | src/VBox/Installer/linux/vboxnet.sh.in > debian/vboxnet.init
|
---|
214 | dh_installinit --name=vboxdrv
|
---|
215 | dh_installinit --name=vboxnet
|
---|
216 | cat debian/preinst.in | sed -e 's|%VER%|$(ver)|g' > debian/preinst
|
---|
217 | if [ "$(debrel)" = "_Ubuntu_dapper" -o "$(debrel)" = "_Debian_sarge" ]; then \
|
---|
218 | cat debian/postrm.dapper > debian/postrm; fi
|
---|
219 | dh_installdebconf
|
---|
220 | dh_installchangelogs
|
---|
221 | dh_link
|
---|
222 | dh_strip --keep-debug --exclude=libVBoxQtCore.so.4 --exclude=libVBoxQtGui.so.4 --exclude=libqtaccessiblewidgets.so
|
---|
223 | # manually strip our R0/GC modules, dh_strip cannot handle them
|
---|
224 | for f in \
|
---|
225 | $(prefix)/usr/lib/$(package)/*.r0 $(prefix)/usr/lib/$(package)/*.gc; do \
|
---|
226 | objcopy --only-keep-debug \
|
---|
227 | $$f \
|
---|
228 | $(prefix)/usr/lib/debug/usr/lib/$(package)/`basename $$f`; \
|
---|
229 | strip -S --remove-section=.comment $$f; \
|
---|
230 | objcopy --add-gnu-debuglink=$(prefix)/usr/lib/debug/usr/lib/$(package)/`basename $$f` $$f; \
|
---|
231 | done
|
---|
232 | mkdir -p $(current)/debian/$(verpkg)-dbg/usr/lib
|
---|
233 | mv $(current)/debian/$(verpkg)/usr/lib/debug $(current)/debian/$(verpkg)-dbg/usr/lib
|
---|
234 | dh_compress -X.pdf -X.chm -X LICENSE
|
---|
235 | dh_fixperms
|
---|
236 | dh_makeshlibs
|
---|
237 | dh_installdeb
|
---|
238 | dh_perl
|
---|
239 | dh_shlibdeps
|
---|
240 | dh_gencontrol -- \
|
---|
241 | -Valsa=$(if $(HEADLESS),,libasound2) \
|
---|
242 | -Vpulse=$(if $(HEADLESS),,libpulse0) \
|
---|
243 | -Vsdlttf=$(if $(HEADLESS),,libsdl-ttf2.0-0) \
|
---|
244 | -Vdkms=$(if $(filter _Ubuntu_gutsy _Ubuntu_hardy,$(debrel)),dkms,)
|
---|
245 | dh_md5sums
|
---|
246 | dh_builddeb
|
---|
247 | endif
|
---|
248 |
|
---|
249 | .PHONY: binary modules binary-arch binary-indep clean checkroot
|
---|